If you update automagically now you will see some new settings available under system settings. These allow you to configure an outgoing email server (smtp) to send signals to your mail or someone else.

After entering the mail settings you can send emails by making a signal that looks like this: email:recipient@server.com:subject:text

If default to is set in settings you can leave that out but keep the :

And do not create loops by making a transform that send all signals as emails.

Johan
27/7/2013 04:55:00

Efter ha kör ditt system ett tag (stabilt) så blev jag tvungen att "börja om" från början med en ny image MEN, nu får jag "HTTP Error 500 - Internal server error" när jag ska lägga till 'on off devices' på en ny sida/remote.
Tror jag gör rätt eller kan det ha o göra med nya uppdateringen. Skulle ju ha provat innan jag uppdaterade, men men.

Reply
David
27/7/2013 23:10:35

Finns det någon möjlighet att du kan logga in över SSH och köra följande kommandon:
cd source/automagically/site
./test.sh

Därefter prova att göra samma manöver men ändra URLen till server så den slutar med :8100

Skicka eventuella utskrifter till min mail eller via pastebin

Reply
David
4/8/2013 06:38:18

Nu har jag lagt upp en fix för ditt problem. Prova att uppdatera och se om det löser sig. Säg till annars.

Reply
Johan
4/8/2013 18:39:15



efter en uppstart:
[FAIL] startpar: service(s) returned failure: mysql ... fail

efter cd source/automagically/site
./test.sh

pi@raspberrypi ~/source/automagically/site $ ./test.sh
Validating models...

Unhandled exception in thread started by <bound method Command.inner_run of <django.contrib.staticfiles.management.commands.runserver.Command object at 0x2173710>>
Traceback (most recent call last):
File "/usr/local/lib/python2.7/dist-packages/django/core/management/commands/runserver.py", line 91, in inner_run
self.validate(display_num_errors=True)
File "/usr/local/lib/python2.7/dist-packages/django/core/management/base.py", line 266, in validate
num_errors = get_validation_errors(s, app)
File "/usr/local/lib/python2.7/dist-packages/django/core/management/validation.py", line 103, in get_validation_errors
connection.validation.validate_field(e, opts, f)
File "/usr/local/lib/python2.7/dist-packages/django/db/backends/mysql/validation.py", line 14, in validate_field
db_version = self.connection.get_server_version()
File "/usr/local/lib/python2.7/dist-packages/django/db/backends/mysql/base.py", line 411, in get_server_version
self.cursor()
File "/usr/local/lib/python2.7/dist-packages/django/db/backends/__init__.py", line 306, in cursor
cursor = self.make_debug_cursor(self._cursor())
File "/usr/local/lib/python2.7/dist-packages/django/db/backends/mysql/base.py", line 387, in _cursor
self.connection = Database.connect(**kwargs)
File "/usr/lib/python2.7/dist-packages/MySQLdb/__init__.py", line 81, in Connect
return Connection(*args, **kwargs)
File "/usr/lib/python2.7/dist-packages/MySQLdb/connections.py", line 187, in __init__
super(Connection, self).__init__(*args, **kwargs2)
_mysql_exceptions.OperationalError: (2002, "Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)")

testade:
cd source/automagically/update
./update.sh

men det blev ingen skillnad...
-------------------------------------------------------
Ska jag testa med en ny image copy?

Reply
Niclas
19/8/2013 01:25:55

Hej efter jag uppdaterat så har jag fått problem med "server error 500" när jag ska tända eller släcka brytare . några tips på vad jag kan göra eller loggar att titta i?

Reply
David
19/8/2013 02:53:53

Hej, tråkigt att höra. Jag skulle börja med att logga in över SSH och köra sudo update.sh i mappen /home/Pi/source/automagically/
I undermappen /site/ finns även test.sh som drar igång en testversion av webservern på port 8100 som ger mer felinformation.

Reply
niclas
19/8/2013 04:32:16

Tyvärr har fortfarande samma problem och när jag körde test.sh så fick jag aldrig något svar ,är det någta andra som har samma problem?
//Niclas
ps har du funderat på att göra så att man kan trigga ett script från en signal.

Kalle
27/8/2013 16:01:01

Fick samma fel. Ta bort åäö från devicens titel så funkar det (tips i annan tråd)

Reply
Nicolai
20/8/2013 05:54:46

Is it possible to add line breaks in the text? I tried with \n, no go.

Reply
Anders Forsberg
3/10/2013 21:48:28

Hej! Jag lyckas inte få mailfunktionen att fungera. Finns det något sätt att testa det på? Jag har sendmail fungerande i RP

Reply



Leave a Reply.