Last night I got a notice about that Jörgen Karlsson has put togheter an installer for Automagically for all of you that want to run it on another system than my preconfigured Raspberry Pi images. If it is another Raspberry Pi system or any other Linux system doesn't matter. This installer is found here:
https://bitbucket.org/jorkar/automagically_install
I took a quick look in it and it might be a little rough (overwritting) on your Apache/MySQL config files but apart from that Jörgen also has nicely written instructions on how to do the installation. (Haven't tried to execute it thou, because I already have automagically installed on my RPi).

Many thanks to Jörgen for this work!
23/9/2013 15:02:46

I'v got it working on both rpi and on a pc running ubuntu with this installer. But please help contribute!

Reply
Johan
3/11/2013 02:24:24

Hej, har nu gjort clean install. (ej preconfigured)
Fungerar att starta.
Det mesta fungerar.
se signals... ok
Ändra login, ok
Lägga till devices, ok
Lägga till remotes, ej ok (Error 500)



Blev ett flel vid installationen:

Vid "sudo ./install.sh" (hade redan utfört steget innan)

ln: failed to create symbolic link `/etc/init.d/automagically': File exists
ln: failed to create symbolic link `/etc/apache2/ports.conf': File exists
ln: failed to create symbolic link `/etc/apache2/sites-enabled/automagically': File exists
ln: failed to create symbolic link `/etc/init.d/automagically': File exists
ln: failed to create symbolic link `/etc/mysql/my.cnf': File exists
ln: failed to create symbolic link `/usr/local/lib/libcec.so': File exists
ln: failed to create symbolic link `/usr/local/lib/libcec.so.1': File exists

[....] Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Sun Nov 03 17:44:14 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting ...apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Sun Nov 03 17:44:19 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
. ok
[ ok ] Stopping MySQL database server: mysqld.
[ ok ] Starting MySQL database server: mysqld . . . ..
[info] Checking for tables which need an upgrade, are corrupt or were
not closed cleanly..



Hur kan jag fixa detta? "symbolic link" vad är detta?
Några tips?

ps -ef ser ut så här:
root 4338 1 0 17:44 pts/1 00:00:00 /bin/sh/usr/bin/mysqld_safe

Reply
NS
23/10/2013 06:45:09

Hi,

I have tried with no luck. I ended up with a 500 internal server error when trying to access the webpage.

Reply
Johan
28/10/2013 04:35:10

Puuuh... Varför fungerar det helt plötsligt inte längre???
Får bara igång Pi:en med senaste "013-09-25-wheezy-raspbian.zip"
Har installerat "automagically_20130505.zip " flera gånger förut, men nu vill den inte längre. Provat flera olika SD kort.
Är det krångligt att installera separat?

En annan fråga, kan man installera OpenHab samtidigt? Eller är det det som ditt system bygger på?

Mvh,
J

Reply
David
28/10/2013 06:06:07

Hej
Det skulle kunna bero på att det någon gång där byttes minneskretsar på RPi vilket kräver "ny" grundimage. Den jag har för nerladdning på hemsidan ska fungera med nya minneskretsar (och gamla). Men detta kan vara en anledning.

OpenHab vet jag inte ens vad det är (dags för google) men jag ser ingen anledning till att det inte skulle gå att installera också. Det som kan krocka är ju webserver-konfiguration men det går ju att lösa om man trixar lite.

Reply
Johan
28/10/2013 08:18:45

Jo, den borde du kolla. Det är någon slags standard.
Min tanke var att ha din setup + Openhab (java) + Motion.
Då blir det en super-setup. Logiken i Automagically > HabDroid > KNX > mm.
Det som är bra med den är uppdateringen i Androidappen (HabDroid).

Det fungerade att installera den ovanpå din Image, men i slutet på instruktionerna ska man ändra något med "sudo usermod -a -G dialout pi" Jag tror det var där något med din "mysql" tog skruv, och blev onåbar. Så jag blev tvungen att börja om. Som sagt fungerar inte din Image längre (för mig), märkligt. Har nog använt den ett 10 tal gånger. Får försöka installera Automagically ovanpå, hoppas det går.

links:

http://morepootling.blogspot.se/2013/09/home-automation-with-z-wave-on.html

Tellstick bindings:

https://code.google.com/p/openhab-samples/wiki/integration#Telldus_Tellstick

pickitup
8/11/2013 21:23:46

Hej,
Senaste RPi imagen funkar inte. Den kan inte starta mysql, någon som har en lösning eller en länk till den versionen innan 2013-11-04?

/Pickitup

Reply
David
9/11/2013 01:09:03

Hej, ja jag har fått det bekräftat från flera håll. Nedladdningssidan är ändrad så gamla fungerande imagen är länkad. Hoppas den fungerar bättre.

//David

Reply



Leave a Reply.